Milan Andric <mand...@gmail.com> writes:

> Hi Folks!
>
> I'm failing to get chromium command line switches to work with
> crosswalk-21.51.546.6. I'm using the embedded style, testing with the
> default android project generated from the crosswalk-app
> (crosswalk-app-tools on npm).
>
> Is there a way to have xwalk or chromium log the command line switcches it
> is using when it launches?  I tested the command line switches on the
> desktop version of Chrome 53 and 51 and they work as expected.  Is there a
> recommended way to test/debug this?  Like a command line switch that is
> definitely supported in the latest xwalk release and makes it very evident
> that it was passed in?
>
> I also tried the more conventional routes using the manifest.json property
> "xwalk_command_line" and the "xwalk-command-line" file in the assets
> folder.  They all failed for me.
>
> Here is the main Activity class:
> https://gist.github.com/mandric/7bf05e750d7ed3b5f907c4fb44abdd8e

Hi,

The recommended way to pass additional flags to Crosswalk or Chromium is
indeed xwalk_command_line or xwalk-command-line.

In this case, I think you're having problems because both --user-agent
and --unlimited-storage are Chrome-the-browser flags. Technically
speaking, they are defined and interpreted in src/chrome/, which means
they won't really have an effect in Crosswalk.

In your snippet you mention you want to get --unlimited-storage to work;
can you elaborate on the reason? Perhaps we can find another way to
achieve the same result.
_______________________________________________
Crosswalk-help mailing list
Crosswalk-help@lists.crosswalk-project.org
https://lists.crosswalk-project.org/mailman/listinfo/crosswalk-help

Reply via email to