[Suspected solution to input problem below.]

Responding to: sl...@troubleshooters.com:

Thanks Steve,

I've accidentally stumbled across a solution to one of my main problems: a
replacement for invoking the old NetworkManager connection panel provided
via gnome-control-center.

For some reason I had previously been unaware of these two:


They now allow me both to select network connections and to edit them. I
can easily invoke them from the command line or a ctwm menu. They seem to
provide everything I need more conveniently than the old mechanisms invoked
via gnome-control-center.

Regarding your recommendation to give up Fedora: I have tried other systems
from time to time, including ubuntu, crunchbang and arch but always
returned to fedora, partly because of familiarity (I started with Redhat 6
around 1999 with my first Dell D400(?) laptop) and partly because I found
some things much cleaner in Fedora than alternatives -- e.g. the location
of 32 bit libraries is where they have always been


and the 64 bit libraries are in

In contrast when I tried using ubuntu for a while, I found the system
incomprehensible. I don't know if all debian-based systems are like that.

Yes: the need to upgrade fedora occurs too frequently for me. I normally
skip one or two generations at a time. I could reduce the frequency of
change by switching to CentOS or Scientific Linux, both of which have been
used in my department.

If I gave up fedora, the first thing I would try would be Arch, because it
avoids the discontinuous version changes of fedora, and its documentation
seems to be superior to documentation provided by all the others. I often
end up getting answers to my fedora questions from Arch web pages.
Another possibility would be CentOS, or possibly Scientific Linux. Neither
changes so frequently.

Re: systemd

I also strongly disliked it when it first arrived, when I was used to
managing the 'rc' directories, but I've got used to systemd now.

E.g. I found the simplest way to suppress bluetooth was to remove some
systemd links, though I think bluetooth firmware still gets loaded at boot.

Re: keyboard/mousepad input problem on laptop

My main remaining problem with F27 now is the strange keyboard/mousepad
behaviour on my Stone/Clevo laptop. The internet now shows a number of
linux users reporting difficulties with input via laptop keypads or mouse
pads, after boot, after hibernate, or after suspend, although external
usb mouse or keyboard works perfectly. There may be different causes at

My problem seems to be connected with the synaptics firmware, including a
"secret" (buggy?) keylogger, which I suspect may have been programmed to go
into a sleep mode after a fixed time if no keyboard/mousepad activity has
been detected, and which can be awakened only by suspend+resume in my

A user reporting a problem like mine mentioned that HP had provided a bios
update that fixed the problem. See comments 13 and 14 here:


The "hidden keylogger" in the synaptics code is reported here

and here:
    HPSBHF03564 rev 2 - Synaptics Touchpad Driver Potential, Local Loss of

I've initiated a request for information about bios updates available for
my Stonebook mini (re-badged Clevo W515LU) through our IT services people.
(I have to be careful not to do anything that could violate my 5 year

All of this raises questions about what linux was doing (perhaps what
libinput was doing?) up to kernel 4.8.6-300 which worked (and still works)
without any of these problems, at least on my laptop, But why does it go
wrong in the later versions I have tried (in F25 and F27) up to

    4.14.18-300.fc27.x86_64 #1 SMP Thu Feb 8 01:35:31 UTC 2018

I've not stuck with 4.8.6-300 because screen handling is not so good,and
there are no longer updates for F25.

I tried going back to an earlier version of libinput instead but that made
no difference. (I am mostly ignorant about all the relevant low level stuff

The fact that there's no record of the timeout, or functionality being
restored, in any linux log file I've search (e.g. /var/log/messages) seems
to be consistent with the problem lying below the level of linux.

The laptop works perfectly at all times with external (usb) mouse and/or
keyboard. And when touchpad/keyboard input is frozen I can also login from
my PC via wifi -- e.g. to work on the laptop using a larger screen.

For now, strangely, functionality is restored (e.g. at boot when laptop
keyboard does not work) by suspend/resume using the laptop lid.

It's bizarre. For most of the rest of the time everything works normally --
except when the laptop goes into a powersave(?) mode after a time and the
built in input devices stop working. But suspend/resume using the laptop
lid restores the functionality.

Very strange.

Thanks for the dmenu suggestion. I'll look more closely after I've caught
up with other things.

Apologies for posting all this non-ctwm stuff to a ctwm list. It may be
useful to others with non-responding laptops.


Reply via email to