It's possible nobody on this list can help me, but just in case, here's the
long story:


For many years I've used ctwm on fedora on PC and Laptop, with a free Windows 10
version also installed, for very occasional use.

In 2020 I bought a new PC with two drives (HDD and SSD) and, perhaps foolishly,
put a boot partition on each drive hoping that would give me extra reliability.

All went well using fedora, and occasionally windows, also installed on both
drives, till fedora became incompatible with zoom, and around the same time made
changes in the latest versions that prevented pulseaudio working as previously.

So I tried installing CentOS in a previously unused partition, and tried using
that, which did not help (e.g. couldn't run zoom), then tried upgrading to a
later version of fedora (37) and that did not help either with running zoom or
with getting useful audio output.

A colleague then suggested I try the 'long-term' version of ubuntu, but I then
discovered that although I could boot from a usb stick with an iso file, I could
not boot without it: apparently the bios had got corrupted.

I was then informed about a bios-fixing tool (to be run on a usb stick -- I've
forgotten its name) which took a very long time but at the end restored the
ability to boot.

I suspect that at that stage I should have removed one of the boot directories,
but did not, and instead managed to install lt-Ubuntu, which has now been
working ok with its standard interface, which I really dislike in comparison
with ctwm.

I then installed the most recent version of ctwm available via the ubuntu
library system, and copied .ctwmrc from my old PC and also the file to go into
the xsessions library.

But any attempt to start ctwm fails.

While trying to set up the ability to start ctwm instead of the standard
Ubuntu interface I encountered problems. I tried using the xsession facility
that would give me the option to boot either into ctwm or the ubuntu wm.

But any attempt to run ctwm fails, so that I have to return to the standard
Ubuntu interface, which I can use, but dislike, as it's far inferior to ctwm for
my kind of multi-strand activity.

Fortunately it doesn't completely crash: I can get back to the standard
ubuntu-lt interface, though I haven't tried rebooting (scared...).

A colleague who uses Ubuntu but not ctwm has been helping me get to this
point tried to help by asking

> What happens if you do
> ctwm --replace

My reply

> I've typed that in an xterm window and it obviously doesnt recognise 
> --replace:

It lists available options, and that isn't one of them

If I type

    ctwm -cfgchk

I get (copying from one screen to another on a different machine):

    m4:stdin:166 cannot undivert `/etc/x11/ctwm/menudefs.hook': No such file or 
    No errors found

I wonder whether this is evidence that the file structure is again corrupted?

Do I have any alternative to running gparted on a usb stick, and using it to
remove one of the /boot directories (which one: HDD or SSD?) and then try
running the bios-fixing program again, and then try to boot the installed
Ubuntu, or failing that, as a last resort create a new version of Ubuntu?

Fortunately, apart from trying to set up configuration details I haven't done
any real work on files in Ubuntu directories that may now be inaccessible.
(I am more concerned about files in the fedora partition, though most of them
had been backed up very recently.)

Main question: does it sound as if my ubuntu system can be rescued and made to
run using ctwm, or do I have to run the bios-fixer again, remove one of the two
/boot regions (keep the SSD one for greater reliability and speed?) and start
installing ubuntu again, then later save all my useful files currently in the
fedora partition and get rid of fedora and centos. (I hope I can avoid
hand-editing bios/boot files, which I have not done for many years!).

I should also consult on whether it's better to use HDD or SSD for swap (and
hibernate). My ancient brain has lost information about that tradeoff!

I assume SSD is OK for boot files, and may allow slightly faster booting.

Advice welcome -- and much appreciated.



Aaron Sloman,
Emeritus Professor of Artificial Intelligence and Cognitive Science
(Retired, but still working full time, on the Meta-Morphogenesis project)

NOTE: if you have recorded my email address as please
change it to [i.e. delete cs]

School of Computer Science,
The University of Birmingham
Birmingham B15 2TT UK

Reply via email to