Yes, I have a nvidia card. (Quadro K1000M)

I installed and ran clinfo but the dt core options still shows opencl
not available.

searched for nvidia-modprobe and it is not found.

I used the fairly simple opensuse install procedure (which worked well
on the previous release) and to make sure I ran the process again
including a reboot.

Any idea where I should go from here?

David

On 08/06/2017 09:47 PM, Ulrich Pegelow wrote:
> Am 07.08.2017 um 04:03 schrieb David Vincent-Jones:
>> I have just moved my openSUSE version from 42.2 to 42.3 and now dt does
>> not appear to recognize the installed openCL.
>>
>> [opencl_init] could not find opencl runtime library 'libOpenCL'
>> [opencl_init] could not find opencl runtime library 'libOpenCL.so'
>> [opencl_init] found opencl runtime library 'libOpenCL.so.1'
>> [opencl_init] opencl library 'libOpenCL.so.1' found on your system and
>> loaded
> 
> This tells us that at libOpenCL.so.1 is present on your system and
> darktable has been able to load it.
> 
>> [opencl_init] could not get platforms: -1001
> 
> That tells us that libOpenCL.so.1 failed when checking for available GPUs.
> 
> I assume you have some NVIDIA card.
> 
> Please try the following. As root call program clinfo (should be
> supplied by package clinfo-2.0.15.03.24-2.3.x86_64 or the like). Then
> start darktable again as a normal user. If darktable now works with
> OpenCl this is an indication of a permission issue on your system.
> 
> NVIDIA relies on a program /usr/bin/nvidia-modprobe that needs to be set
> SUID root. I found that frequently distributions remove the SUID bit for
> security reasons. It's up to you if you set it manually (chmod +s
> /usr/bin/nvidia-modprobe).
> 
> Ulrich
> 
____________________________________________________________________________
darktable user mailing list
to unsubscribe send a mail to darktable-user+unsubscr...@lists.darktable.org

Reply via email to