Hi Emanuele,

Emanuele Rocca wrote:
> On 2023-10-10 01:45, Axel Beckert wrote:
> > I tried that, installer ran through fine, grub boots from disk after
> > installation, kernel loads initramfs and then falls into the initramfs
> > prompt and fractions of a second later (sometimes even beforehand) the
> > whole screen goes black and then nothing helps then pressing the power
> > button for about 10 seconds.
> This sounds like you might have missed the wiki step "Add qnoc-sc8280xp
> module to initramfs":
> https://wiki.debian.org/InstallingDebianOn/Thinkpad/X13s

I indeed missed that first, but fixed it via rescue mode of the
d-i image.

> OK then once you chroot into the installed system you should be able to
> check if qnoc-sc8280xp is in /etc/initramfs-tools/modules. If not,
>  echo qnoc-sc8280xp >> /etc/initramfs-tools/modules

Was already in there.

> To triple-check that the needed module is in there:
>  zstdcat /initrd.img | cpio -itv | grep qnoc-sc8280xp.ko

Was also already in there.

Additionally there are quite some messages about things being pending
due to waiting for something else from that kernel module seconds
before the screen blanks. Can send pictures I made of it, in case they
could be helpful.

And since you've mentioned /initrd.img instead of /boot/initrd.img (as
I have a single filesystem installation for now), I also added a
symlink at /initrd.img pointing to /boot/initrd.img. But it didn't
change anything either. (I later noticed that this likely was
unnecessary as GRUB also looks for kernel and initrd.img under /boot
and for a versioned file anyways.)

> In any case, the daily netinst image should now work!

Indeed. Had to use that to check the above today as the mini.iso no
more works due to the updated kernel in sid.

> There's no need to manually copy any firmware and similar
> shenanigans.

Well, still quite some shenanigans left for now.

> If you have the time, please follow the
> InstallingDebianOn/Thinkpad/X13s page again from the begingging to
> the end (quite a few things have changed) and let me know if that
> works for you.

Haven't done a reinstallation for now. (And I'm actually not that keen
on it currently, but I will have to do it at some point, because I
forgot to enable disk encryption. But I'd first like to understand
what's wrong as I seem to have followed all steps.)

Via d-i's rescue mode I have also updated the kernel to 6.5.0-2, but
the symptoms stay: Lots of "pending/waiting for" message by
qnoc-sc8280xp and then a dark, blank screen and nothing happens

                Regards, Axel
 ,''`.  |  Axel Beckert <a...@debian.org>, https://people.debian.org/~abe/
: :' :  |  Debian Developer, ftp.ch.debian.org Admin
`. `'   |  4096R: 2517 B724 C5F6 CA99 5329  6E61 2FF9 CD59 6126 16B5
  `-    |  1024D: F067 EA27 26B9 C3FC 1486  202E C09E 1D89 9593 0EDE

Reply via email to