On Thu, Dec 01, 2016 at 07:21:32PM +0500, Andrey Rahmatullin wrote:
> As there is not enough data in the message, I'm assuming it's about the
> published repo.
> The upstream/2.4.0 tag is not merged into master so the debian/2.4.0-*
> tags are not its descendants. This will not work properly.
> Try merging that tag into master now, before importing the new version,
> this will probably help.
> 
> > I can confirm the very same observation in another case ncbi-tools6[1]:
> > 
> > $ TMPDIR=/var/tmp gbp import-orig --pristine-tar 
> > ../ncbi-tools6_6.1.20160908.orig.tar.gz
> > Make sure we use sid config
> > What is the upstream version? [6.1.20160908] 
> > gbp:info: Importing 
> > '/home/tillea/debian-maintain/alioth/debian-med_git/ncbi-tools6_6.1.20160908.orig.tar.gz'
> >  to branch 'upstream'...
> > gbp:info: Source package is ncbi-tools6
> > gbp:info: Upstream version is 6.1.20160908
> > gbp:info: Merging to 'master'
> > gbp:error: Automatic merge failed.
> > gbp:error: Error detected, Will roll back changes.
> > gbp:info: Rolling back branch upstream by resetting it to 
> > be323245ea77f0e457e3d42c83b58a82f67ca0f2
> > gbp:info: Rolling back branch pristine-tar by resetting it to 
> > 4379fc7d56641c4c4ee7612c48385c8927fac5c8
> > gbp:info: Rolling back tag upstream/6.1.20160908 by deleting it
> > gbp:info: Rolling back branch master by resetting it to 
> > 7c27f101e5f5bcc188d55a67a5d11ead7dbbe62c
> > gbp:info: Rolling back failed merge of upstream/6.1.20160908
> > gbp:error: Rolled back changes after import error.
> > 

I tried to apply your hint to ncbi-tools6[1] but this does not change
anything:

ncbi-tools6(master) $ LC_ALL=C git merge upstream/6.1.20120620
Already up-to-date.

Did I missinterpreted your hint?

Kind regards

      Andreas.

> > [1] https://anonscm.debian.org/git/debian-med/ncbi-tools6.git

-- 
http://fam-tille.de

Reply via email to