Did you regenerate the initrd after the dist upgrades?

Some systemd packages are in the initrd and you need to make sure those are 
updated as well.

If that still doesn’t help, try downgrading systemd.


> On Feb 4, 2018, at 4:48 PM, Frank Scheiner <frank.schei...@web.de> wrote:
>> On 02/04/2018 04:30 PM, John Paul Adrian Glaubitz wrote:
>>> On 02/04/2018 04:22 PM, Frank Scheiner wrote:
>>> Thanks Adrian, tried that, but didn't help. After a restart, segfaults 
>>> still happen when trying to login via serial console. But in the process of 
>>> `apt -f
>>> install` also libc-bin, libc-dev-bin, libc6 and libc6-dev were upgraded 
>>> again. Not sure if I should have canceled those upgrades after:
>> Yes, your packages are no up-to-date if you're still on glibc_2.25.
> They weren't up-to-date before doing `apt -f install` as I downgraded to the 
> version of libc I had before doing the upgrade yesterday. But libc got 
> updated to 2.26 during `apt -f install` - a recent segfault message also 
> shows this:
> ```
> v245 login: [   46.563987] e1000e: enp8s0f0 NIC Link is Up 1000 Mbps Full 
> Duplex, Flow Control: Rx/Tx
> [   46.564690] IPv6: ADDRCONF(NETDEV_CHANGE): enp8s0f0: link becomes ready
> root
> Password:
> [   51.434172] login[622]: segfault at 30 ip ffff800100517644 (rpc 
> ffff8001020f9d54) sp 000007feffb7c451 error 1 in 
> libc-2.26.so[ffff80010046c000+15e000]
> ```
> Only the other (systemd related) packages I downgraded earlier were still on 
> the older versions after the reboot. But I now did an `apt dist-upgrade` with 
> `/etc/apt/sources.list`:
> ```
> deb http://ftp.ports.debian.org/debian-ports/ sid main
> deb http://ftp.ports.debian.org/debian-ports/ experimental main
> deb http://ftp.ports.debian.org/debian-ports/ unreleased main
> ```
> ..so they should be up-to-date now. But that also didn't help, after a 
> reboot, segfaults still happen when trying to login via serial port.

Reply via email to