2018-07-18 7:34 GMT+02:00 Romain Dolbeau <rom...@dolbeau.org>:
> That's where I am a right now. I'll try to rebuild Debian ZFS in the chroot
> instead of the installed Debian next...

Ended up doing 'mkdir' of the missing directory during build, solved
the problem.

Then the new ZFS, being older, didn't import the pool... so I
recreated the pool from scratch.

debootstrap would then fails, trying to download some packages
upgraded during the night... after a while and multiple attempts it
worked. Dunno why.

So redo everything, but for some reason grube-probe doesn't see ZFS
anymore. And the pool name is missing in grub.cfg, I can fix that by

Still can't boot, as the klibc stuff has been updated from -12+sparc64
to -13, getting me back to square one. Still had the -12+sparc64 in
the ext4 install, so downgrade by hand and bypass that problem.

At this stage (and probably some stuff I forgot), the new install will
boot single user :-) But multi-user hangs during start-up after:
[  OK  ] Reached target Network is Online.
         Starting LSB: exim Mail Transport Agent...
[  OK  ] Started Permit User Sessions.
[  OK  ] Started Getty on tty1.
[  OK  ] Reached target Login Prompts.
[  OK  ] Started LSB: exim Mail Transport Agent.
[  OK  ] Reached target Multi-User System.
[  OK  ] Reached target Graphical Interface.
         Starting Update UTMP about System Runlevel Changes...
[  OK  ] Started Update UTMP about System Runlevel Changes.

A few minutes later, I also got:

[  318.639989] random: crng init done
[  318.640079] random: 7 urandom warning(s) missed due to ratelimiting
So I guess the kernel still alive ... (no ping though, and
non-responsive console).


Romain Dolbeau

Reply via email to