2018-07-20 23:22 GMT+02:00 Chris Ross <cross+deb...@distal.com>:
> Interesting.  What tool is showing that?

fdisk, force of habits...

> I have been using parted, which
> shows (for my first ZFS disk):
> Number  Start  End    Size   File system  Flags
>  1      0.00B  502MB  502MB  ext2         boot
>  2      502MB  147GB  146GB  zfs
> So, other than the different format, I notice:
> 1) I show ZFS where your sdd2 shows "Unassigned"

I used fdisk and originally set the partition *ID* to unassigned as fdisk
didn't suggest ZFS. ZFS doesn't seem to care.
Parted shows a filesystem, not an id (I think).
fdisk shows the id, not the filesystem.

> 2) You have a 'c' whole disk partition, and I don't.  I wonder if that's
>    important?

Suns have wanted a full disk partition since the beginning.
Sun labels tend to always have them, just in case.
Not sure if they are used by anything in Linux (I doubt it,
it's probably just an artifact of SunOS behavior).

> 3) You have an "Id" field [in your tools output] that I don't.

partition Id used to be useful, not sure if anything in the kernel
cares anymore. fdisk still offers to set them and still display them -
as said above, I put unassigned by lack of choices. Don't think it
matters much.

> Thanks.  There are a few differences compared to mine, notably that the
> "search" lines in your menuentry have a UUID of all 9's,

Oups sorry red herring - out of habits I always anonymize such files.
In my installation, the UUID are real values, and I sed'ed them to all-9.

> And I have hd0/ahci0 vs your hd3/ahci3, but that is expected.  I
> also see that I'm due a kernel update (my grub.cfg still lists 4.16.0-2),
> but since I'm not getting a kernel loaded at all, that's not my problem.

I had to update the kernel as the 4.16 installed by the installer didn't
have any matching headers to compile ZFS that I could find. 4.17
worked just fine on ext4, and works just fine with ZFS as well, and it
had headers.

> Yeah.  This is about the same as what I've tried, but I'm not even able
> to have grub load from the disk in my case.  I've been thinking about
> booting back to "reinstall the whole thing from CD", since my original
> install was many months ago, but haven't done that yet.

Except for holding the klibc stuff to a working version, you should be able
to just dist-upgrade I suppose. I did in my case to make sure I would have
matching install between ext4 and ZFS during dbootstrap, so I could reuse
the same ZFS/SPL modules without any compatibility issue.

As for grub - except for the fact my /boot is much smaller (I matched
the size of the ext4 auto-created partition to the sector), I can't help.
My first attempt failed - not valid. After trying again, it started working
and I just had to fix the various issues in configuration and versions
mentioned in a previous mail. I don't think I did anything special beyond
slightly fixing the grub.cfg by adding the pool name...

Good luck & cordially,

Romain Dolbeau

Reply via email to