Same problem on my ASUS GL703VD.
I tried the 18.04 beta today starting a live session with the suggested boot 
option (modprobe.blacklist=nouveau).
I can work using an external monitor connected to the HDMI interface. The 
laptop display become black during the boot just after few seconds but I can 
see the boot progress on the external monitor.

The system works fine with Ubuntu 17.10 with the old kernel
4.13.0-38-generic.

I tried the new kernel 4.16 with ubuntu 17.10 from the mainline
repository but the problem is the same: black laptop screen during boot,
external HDMI monitor working.

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xserver-xorg-video-nouveau in Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
  nouveau/nvidia drivers do not work with display in Bionic on Asus
  GL703VD Laptop

Status in nvidia-graphics-drivers-390 package in Ubuntu:
  Confirmed
Status in xserver-xorg-video-nouveau package in Ubuntu:
  Confirmed

Bug description:
  Tried to install Bionic Desktop on my Asus GL703VD ROG Laptop with
  NVIDIA GTX 1050M Video Card (with i915 Intel graphics card when not
  using 3D) and the installer does not display. I have tried
  nouveau.modeset=0 and nomodeset boot options to no avail. I was able
  to finally install Bionic by hooking up the laptop to a projector, but
  after a reboot, the laptop display still did not work and I had to set
  the account to autologin otherwise I could not login to the laptop. I
  then install openssh-server so that I could ssh into the laptop and I
  installed the nvidia-390 drivers from ppa:graphics-drivers/ppa which
  installed, but still no local display.

  In Artful, I could install with the nouveau.modeset=0 and then
  installing the proprietary NVIDIA drivers and everything (except
  touchpad, LP: 1738263) worked.

  lspci shows the graphics card and NVIDIA card, and lsmod does show
  that before NVIDIA drivers install, it is using nouveau, asus_wmi, and
  i915 for graphcis, and once NVIDIA drivers are install, lsmod only
  shows i915 and asus_wmi for graphics while nvidia is used for gpu and
  3D, but still no display on the laptop.

  lsmod_prenvidia.txt shows the nouveau driver and the /proc/cmdline
  lsmod_nvidia.txt shows nvidia drivers installed and the /proc/cmdline
  lspci.txt shows the detected hardware
  lshw.txt shows the hardware in the laptop.

  Please let me know if you need any other information.

  Thanks,
  Luke

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to