Github user ctubbsii commented on a diff in the pull request:
    --- Diff: core/src/main/java/org/apache/accumulo/core/file/rfile/ 
    @@ -1164,11 +1167,7 @@ private Reader(Reader r, boolean useSample) {
         private void closeLocalityGroupReaders() {
           for (LocalityGroupReader lgr : currentReaders) {
    -        try {
    -          lgr.close();
    -        } catch (IOException e) {
    -          log.warn("Errored out attempting to close LocalityGroupReader.", 
    -        }
    +        lgr.close();
    --- End diff --
    If `currentReaders` were changed to an ArrayList, this could use the stream 
`forEach`. Not sure if that would impact performance, but it'd probably improve 
readability in a few places.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

Reply via email to