Hey folks. I need to narrow down the name for one of the parameters on the Deadline Alerts work and I'm fishing for suggestions.
TLDR: need_by_date = {some existing timestamp} + {a user-defined timedelta} The existing timestamp could be dynamic (like when the dagrun is queued or when a specific task stars, etc), or fixed datetime. So in practice this will look something like: need_by = DeadlineTrigger.DAGRUN_QUEUED + timedelta(hours=1) where the DeadlineTrigger is the part we are trying to rename. I initially used Anchor in the AIP for lack of a better name and it was universally hated. I like Trigger better, but that name is already overloaded in Airflow so I don't want to reuse it. Maybe Reference? need_by = DeadlineReference.DAGRUN_STARTED + timedelta(minutes=30? Please throw some other suggestions or naming thoughts on the pile and maybe we can come up with something good. - ferruzzi