Reformat the CP-DP synchronization sequence diagram in bpf_pkt.c by removing unnecessary vertical lines and re-centering arrow labels.
This comment-only commit is intentionally kept separate to make the diff of the preceding semantic change more readable. Signed-off-by: Marat Khalili <[email protected]> --- lib/bpf/bpf_pkt.c | 22 +++++++++------------- 1 file changed, 9 insertions(+), 13 deletions(-) diff --git a/lib/bpf/bpf_pkt.c b/lib/bpf/bpf_pkt.c index 7ae64ed7d0..ea7e240494 100644 --- a/lib/bpf/bpf_pkt.c +++ b/lib/bpf/bpf_pkt.c @@ -52,27 +52,23 @@ * | | | | | | * | |<---------------------- fetch callback -----------------------| * | | | | | | - * | | |<------------- store 1 -----------------------| + * | | |<------------------ store 1 ------------------| * | | | | | | * |-- remove callback -->| | | | rte_smp_mb() * | | | | | | * | | | |<------ fetch non-NULL --------| * | | | | | | - * |------------------- store NULL --------------------->| | | - * | | | | | | - * rte_smp_mb() | | | | | - * | | | | | | - * +-while use is 1 | | | | if cb not NULL-+ - * | | | | | | | | - * | +------------ fetch 1 -------------->| | |<-- execute --+ | - * | | | | | | BPF program | | - * | | | | | | +-+ + * |------------------- store NULL --------------------->| | if cb not NULL-+ + * | | | | | | | + * rte_smp_mb() | | | |<-- execute --+ | + * | | | | | BPF program | | + * +-while use is 1 | | | | +-+ * | | | | | | | - * | | | | | | rte_smp_rmb() + * | +------------ fetch 1 -------------->| | | rte_smp_rmb() * | | | | | | | - * +-+ | |<------------- store 0 -----------------------| + * +-+ | |<------------------ store 0 ------------------| * | | | | | | - * |------------- fetch 0 --------------->| | | | + * |-------------- fetch 0 -------------->| | | | * | | | | | | * |----------------- destroy BPF program and cleanup ----------------->| | * | | | | | | -- 2.43.0

