[ 
https://issues.apache.org/jira/browse/SOLR-3613?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13411884#comment-13411884
 ] 

Jan Høydahl commented on SOLR-3613:
-----------------------------------

I've always thought of Solr as a web-app; a thin HTTP layer around Lucene, and 
we do not bother with how people choose to deploy the app or on what appserver. 
The only reason we ship with Jetty is as an example.

What do we gain in restricting deployment options, as long as it's simple 
enough to keep Solr a clean web-app?

Wrt. SolrCloud - consistency in startup param naming should go before back 
compat, as there is no release version to be back compatible with and no books 
in the shelves. This is one of the risks of running TRUNK or ALPHA before a 
FINAL release. Besides, with the proposed addition to solr.xml it is easy 
enough for end users to change these back to whatever namespace they wish.
                
> Namespace Solr's JAVA OPTIONS
> -----------------------------
>
>                 Key: SOLR-3613
>                 URL: https://issues.apache.org/jira/browse/SOLR-3613
>             Project: Solr
>          Issue Type: Improvement
>    Affects Versions: 4.0-ALPHA
>            Reporter: Jan Høydahl
>             Fix For: 4.0
>
>
> Solr being a web-app, should play nicely in a setting where users deploy it 
> on a shared appServer.
> To this regard Solr's JAVA_OPTS should be properly name spaced, both to avoid 
> name clashes and for clarity when reading your appserver startup script. We 
> currently do that with most: {{solr.solr.home, solr.data.dir, 
> solr.abortOnConfigurationError, solr.directoryFactory, 
> solr.clustering.enabled, solr.velocity.enabled etc}}, but for some opts we 
> fail to do so.
> Before release of 4.0 we should make sure to clean this up.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to