[
https://issues.apache.org/jira/browse/SOLR-3613?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13411901#comment-13411901
]
Jan Høydahl commented on SOLR-3613:
-----------------------------------
An example I just thought about is all the Java CMSes, ECMs and other systems
now integrating Solr as their bundled search engine. They tend to integrate
Solr alongside their other apps, for small and medium installs, and advice the
customers to move it to a dedicated server when things grow big. One of these
is [Escenic Content Engine|http://www.vizrt.com/products/vizrt_online_suite/],
Solr here runs at {{/solr/}} alongside the {{/escenic/}} editors webapp,
{{/escenic-admin}} administrator webapp and {{/studio}} studio webstart webapp.
In the same physical appserver/JVM the customer (typically newspapers) deploy
their newspaper webapp(s), with any number of libs, Java-opts etc.
I think this will be a more and more common case going forward, and a big
reason to keep Solr a web-app, and making it as intuitive as possible to deploy
and configure it.
> Namespace Solr's JAVA OPTIONS
> -----------------------------
>
> Key: SOLR-3613
> URL: https://issues.apache.org/jira/browse/SOLR-3613
> Project: Solr
> Issue Type: Improvement
> Affects Versions: 4.0-ALPHA
> Reporter: Jan Høydahl
> Fix For: 4.0
>
>
> Solr being a web-app, should play nicely in a setting where users deploy it
> on a shared appServer.
> To this regard Solr's JAVA_OPTS should be properly name spaced, both to avoid
> name clashes and for clarity when reading your appserver startup script. We
> currently do that with most: {{solr.solr.home, solr.data.dir,
> solr.abortOnConfigurationError, solr.directoryFactory,
> solr.clustering.enabled, solr.velocity.enabled etc}}, but for some opts we
> fail to do so.
> Before release of 4.0 we should make sure to clean this up.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]