[
https://issues.apache.org/jira/browse/SOLR-3613?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13411972#comment-13411972
]
Robert Muir commented on SOLR-3613:
-----------------------------------
{quote}
Supporting only Jetty? We shouldn't go there. Not supporting other app-servers
is going backwards. The customers of aforementioned Escenic Content Studio (and
other applications embedding Solr) can freely choose what app-server to run
their online newspaper on (http://en.wikipedia.org/wiki/Escenic). Do you want
them to stop using Solr because we "drop" support for anything but Jetty, or
force them and their customers into spinning up a Jetty process alongside their
ECM? That sucks.
{quote}
Its a fact we only support Jetty: its the only thing we test. I don't care
about the relative merits of app servers.
I don't care if we *should* or *should not* support anything else. I don't want
to be involved in that.
I'm just talking about what we have tests for.
This a basic fact: there are only unit tests for Jetty.
My problem is that we advertise Tomcat right on the front page, but there are
no unit tests for it,
thus encouraging users to go with an untested configuration.
I think we should just replace the word 'Tomcat' with 'Jetty' there.
> Namespace Solr's JAVA OPTIONS
> -----------------------------
>
> Key: SOLR-3613
> URL: https://issues.apache.org/jira/browse/SOLR-3613
> Project: Solr
> Issue Type: Improvement
> Affects Versions: 4.0-ALPHA
> Reporter: Jan Høydahl
> Fix For: 4.0
>
>
> Solr being a web-app, should play nicely in a setting where users deploy it
> on a shared appServer.
> To this regard Solr's JAVA_OPTS should be properly name spaced, both to avoid
> name clashes and for clarity when reading your appserver startup script. We
> currently do that with most: {{solr.solr.home, solr.data.dir,
> solr.abortOnConfigurationError, solr.directoryFactory,
> solr.clustering.enabled, solr.velocity.enabled etc}}, but for some opts we
> fail to do so.
> Before release of 4.0 we should make sure to clean this up.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]