[
https://issues.apache.org/jira/browse/SOLR-3613?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13411917#comment-13411917
]
Mark Miller commented on SOLR-3613:
-----------------------------------
Personally, I think if you want to embed Solr, go ahead and use embedded Solr -
else run it as it should be run - in it's own process with it's own heap.
net/net, there are so many positives to simplifying - and this does not sound
like a big negative to me?
bq. advice the customers to move it to a dedicated server when things grow big.
If you are going to end up moving Solr to another server anyhow, I see no
problem with starting with it as a separate process on the same server. That
seems more consistent and a more straightforward transition to me.
I think the decision to make a search engine a war was more about ease of
picking up http plumbing at the time more than any desire to behave like a
typical low resource webapp. At least that's what would make sense to me.
> Namespace Solr's JAVA OPTIONS
> -----------------------------
>
> Key: SOLR-3613
> URL: https://issues.apache.org/jira/browse/SOLR-3613
> Project: Solr
> Issue Type: Improvement
> Affects Versions: 4.0-ALPHA
> Reporter: Jan Høydahl
> Fix For: 4.0
>
>
> Solr being a web-app, should play nicely in a setting where users deploy it
> on a shared appServer.
> To this regard Solr's JAVA_OPTS should be properly name spaced, both to avoid
> name clashes and for clarity when reading your appserver startup script. We
> currently do that with most: {{solr.solr.home, solr.data.dir,
> solr.abortOnConfigurationError, solr.directoryFactory,
> solr.clustering.enabled, solr.velocity.enabled etc}}, but for some opts we
> fail to do so.
> Before release of 4.0 we should make sure to clean this up.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]