One thing to note is that binaries-list expects the hashes to be
upper-case, while the sum on the maven central is lower case. I.e.:
4AE44A6157E1BC4C5B373BE0C274A8F1D9BADD76
is expected instead of:
4ae44a6157e1bc4c5b373be0c274a8f1d9badd76

Jan


On Tue, Mar 13, 2018 at 4:35 PM, Christian Bourque <
christian.bour...@gmail.com> wrote:

> Thanks Jaroslav, I'll have a look at this class and maybe I'll understand
> what is going on!
>
> On Tue, Mar 13, 2018 at 10:45 AM, Jaroslav Tulach <
> jaroslav.tul...@gmail.com
> > wrote:
>
> > Hard to say without debugging. You can find the code here:
> > https://github.com/apache/incubator-netbeans/blob/
> > master/nbbuild/antsrc/org/netbeans/nbbuild/extlibs/
> > DownloadBinaries.java#L368
> > -jt
> >
> >
> > 2018-03-13 14:44 GMT+01:00 Christian Bourque <
> christian.bour...@gmail.com
> > >:
> >
> > > Hey guys,
> > >
> > > Thanks for your replies!
> > >
> > > But I think I wasn't clear enough in my original post: basically my
> > > question is why is NetBeans expecting a different hash value than the
> one
> > > found on Maven Central?
> > >
> > > C.
> > >
> > >
> > > On Tue, Mar 13, 2018 at 4:29 AM, Jaroslav Tulach <
> > > jaroslav.tul...@gmail.com>
> > > wrote:
> > >
> > > > Did you built JGit from source and installed it into local Maven
> > > > repository? Then the locally built version takes precedence over the
> > one
> > > in
> > > > the Maven central and has, of course, different SHA. Adjust the SHA
> or
> > > > delete the local copy from .m2/repository and let the build download
> > the
> > > > real version from Maven central.
> > > >
> > > > -jt
> > > >
> > > > PS: My experience tells me this is painful, sorry for the hassle.
> > > >
> > > >
> > > > 2018-03-13 1:48 GMT+01:00 Christian Bourque <
> > christian.bour...@gmail.com
> > > >:
> > > >
> > > > > Hi all,
> > > > >
> > > > > I'm currently trying to compile NetBeans 9.0 with a more recent
> > Eclipse
> > > > > JGit library (the one currently bundled with
> > > > > NetBeans is 3 years old!) but I'm having a hard time with the hash
> > > (sha1)
> > > > > value that is used by the build system that's
> > > > > downloading the artefact from the Maven Central repository! When I
> > > build
> > > > > NetBeans it says that the hash value
> > > > > that I put in the binaries-list file doesn't match the hash of the
> > > > artefact
> > > > > found on Maven Central, but I took the hash
> > > > > value directly from the Maven Central repository so I expected it
> to
> > be
> > > > > correct:
> > > > > http://central.maven.org/maven2/org/eclipse/jgit/org.
> > > eclipse.jgit/4.11.0
> > > > .
> > > > > 201803080745-r/
> > > > >
> > > > > So then I decided to download the Eclipse JGit source code from
> > GitHub:
> > > > > https://github.com/eclipse/jgit/releases/tag/v4.11.0.
> 201803080745-r
> > > > > compile it and generate the sha1sum myself. To my surprise the
> > computed
> > > > > checksum was equal to the one expected by NetBeans during the build
> > > > > process.
> > > > >
> > > > > So I'm a bit puzzled! If the build script is downloading an
> external
> > > > > dependency from Maven Central then the hash should
> > > > > match the one found in this file:
> > > > > http://central.maven.org/maven2/org/eclipse/jgit/org.
> > > eclipse.jgit/4.11.0
> > > > .
> > > > > 201803080745-r/org.eclipse.jgit-4.11.0.201803080745-r.jar.sha1
> > > > >
> > > > > Anyway, if anyone could shed some light on this situation I would
> > > really
> > > > > appreciate it!
> > > > >
> > > > > Thanks,
> > > > >
> > > > > Christian
> > > > >
> > > >
> > >
> >
>

Reply via email to