FYI, I created https://issues.apache.org/jira/browse/SLING-5343 with a proposed patch attached.
Regards Julian On Tue, Dec 1, 2015 at 11:12 AM, Julian Sedding <[email protected]> wrote: > Are we "allowed" to abbreviate "Apache Sling" to "sling"? > > The pool name can be set by configuration or by a consuming bundle, > e.g. "Apache Sling Job Thread Pool" is set by the EventingThreadPool > implementation. Therefore I lean to a mixed-case format (despite the > fact that I normally prefer all lower-case ;) ). > > So what about shortening the initial proposal to "Apache Sling: Job > Thread Pool #1", i.e. "Apache Sling: <pool name> #<counter>"? > Depending on the reply to my first question we can also drop the > "Apache" prefix. > > Regards > Julian > > > On Tue, Dec 1, 2015 at 10:52 AM, Bertrand Delacretaz > <[email protected]> wrote: >> On Tue, Dec 1, 2015 at 10:35 AM, Chetan Mehrotra >> <[email protected]> wrote: >>> ...It would be better to keep it short as it get used in logs/stacktrace >>> etc. So something like "sling-<pool name>-<counter>" ... >> >> +1 >> >> -Bertrand
