+1 I find this to be way more explicit. Kinda got tripped by this a while back.
On Tue, Sep 20, 2016 at 3:38 PM, Daniel Kuppitz <[email protected]> wrote: > +1 > > On Tue, Sep 20, 2016 at 3:35 PM, Marko Rodriguez <[email protected]> > wrote: > > > Hi, > > > > I was thinking that store() and aggregate() should simply be “store().” > > > > store() -> store(local) > > aggregate() -> store(global) > > > > Or: > > > > aggregate() -> barrier().store() > > > > Random thoughts… > > > > Marko. > > > > http://markorodriguez.com > > > > > > > > >
