yeah I like the barrier().store() best as well.

On Wed, Sep 21, 2016 at 11:46 AM, Jean-Baptiste Musso <jbmu...@gmail.com>
wrote:

> I think barrier().store() for .aggregate() is very appropriate and fully
> tells what is going on.
>
> I like both, +1 for one or the other.
>
> People also tend to confuse .as() and .store()/.aggregate().
>
> On Tuesday, 20 September 2016, Marko Rodriguez <okramma...@gmail.com>
> wrote:
>
> > Hi,
> >
> > I was thinking that store() and aggregate() should simply be “store().”
> >
> >         store()         -> store(local)
> >         aggregate()     -> store(global)
> >
> > Or:
> >
> >         aggregate() ->  barrier().store()
> >
> > Random thoughts…
> >
> > Marko.
> >
> > http://markorodriguez.com
> >
> >
> >
> >
>
> --
> Jean-Baptiste
>

Reply via email to