Well, I wouldn't mind changing the name to getPrecedenceScore(), but that's just naming issue. Two request mappers can handle same URL, i.e. one is for /mount/point and one is for /mount/point/more/specific. How would you decide which one gets to handle the request?
-Matej On Tue, Oct 6, 2009 at 6:53 PM, Eelco Hillenius <eelco.hillen...@gmail.com> wrote: > Looks like an overall improvement. Definitively reduces the spaghetti > a bit. Not crazy about getCompatibilityScore though. I understand it's > purpose and maybe it's the best solution, but it looks like a crutch. > > Eelco > > On Tue, Oct 6, 2009 at 8:13 AM, Igor Vaynberg <igor.vaynb...@gmail.com> wrote: >> ahha, here is something we need to change. we should have a >> mountedmapper that allows one to mount a requesthandler rather then a >> page. the user should not go as far as having to implement >> requestablepage, there are a lot of extraneous methods there if all >> you want to do is handle the request yourself. >> >> -igor >> >> On Tue, Oct 6, 2009 at 3:08 AM, Daniel Stoch <daniel.st...@gmail.com> wrote: >>> The great thing for me is that I'll be able to mounting something that >>> just implements RequestablePage interface, not only a Page class >>> descendants (if I've read this code correctly :)). It allows to handle >>> navigation more flexible and it allows to avoid creating hard to >>> maintain page class hierarchies. >>> >>> -- >>> Daniel >>> >> >