On Friday, 10 January 2014 at 00:04:41 UTC, Jameson Ernst wrote:
On Thursday, 9 January 2014 at 23:15:12 UTC, Alexander Bothe wrote:
On Thursday, 9 January 2014 at 22:50:09 UTC, Daniel Kozak wrote:
On Thursday, 9 January 2014 at 21:47:40 UTC, Alexander Bothe wrote:

So btw, could you please define 'does not work'? Is there an exception, is there just a silent quit, is there a mysterious return value -1 when executing the program with the debugger?


Have you tried other code samples?

Have you tried stepping through code?

Have you tried examing locals via the 'Locals' pad?

Just try to put in a thing like throw new Exception(); to see whether it's about breakpoints.

Or try to hack in a breakpoint via asm { int 0xcc; } (dunno the x64 equivalent though :-/) or asm { int3; }

Ok, I tried cloning the repo for the debugger plugin and building it from source, and it DOES work now. Strange. Something about the one in the addin repository must be subtly different. The video Daniel posted is exactly what happens when using the one from the addin repo. Program execution WILL stop on a breakpoint, but the IDE remains unaware of that fact and acts as if the program is still executing. Throwing an exception manually DOES cause it to stop though, at which point I can examine locals as normal. So the problem seems to relate specifically to breakpoints.

Got to test in my VM. If it's not working there either, I'll just
put the pre-built dll up in my
https://github.com/aBothe/mono-d-bin rage-repo (just to bypass
this ugly addins.md.com building system crap :-D )

Anyway, you can set logGdb
to be true to let it dump every interaction between Mono-D and
gdb - might be good to know what's wrong with the
breakpoints..I'd be happy if it was MonoDevelop-related, but
well, gotta check it, too.

Thanks for testing it so far :)

At any rate, building the plugin from source seems to be the ticket. If you want me to test out anything else, I'd be happy to, since I think it's important this should work out of box for as many people as possible. It is worth noting that I had the same symptoms when using mono-d debugging on a Linux Mint 15 install, so it's nothing specific to Arch.

kk :-)

Reply via email to