Joseph Rushton Wakeling:
Latest patches rename randomSample => sample, again offering a documented alias to assist migration.
Perhaps it's better to not document this alias.
"permutation" seems good to me (or "permute"?), but perhaps others have suggestions or can point to a typical naming practice from other languages?
I'd like a permutations() range in std.range or std.combinatorics. permutation() sounds a bit too much close, despite it is inside another module.