On Saturday, 22 March 2014 at 20:09:00 UTC, bearophile wrote:
Perhaps it's better to not document this alias.
For now it will be documented, for clarity if nothing else. Whether that documentation makes it into a Phobos submission, I think should depend on formal review.
I'd like a permutations() range in std.range or std.combinatorics. permutation() sounds a bit too much close, despite it is inside another module.
How does your desired concept relate to the existing std.algorithm.nextPermutation ... ?