On Tuesday, 1 November 2016 at 16:40:42 UTC, Andrei Alexandrescu wrote:
On 11/01/2016 11:41 AM, Johan Engelen wrote:
On Monday, 31 October 2016 at 01:27:08 UTC, Martin Nowak wrote:
Glad to announce D 2.072.0.

DMD 2.072.0 miscompiles/uncovers a bug in LDC, so I switched back to DMD
2.071.2 for CI testing. :(

Is there somebody working on that bug? Thanks. -- Andrei

LDC built with DMD 2.072.0 gives the following error when run:
object.Error@src/rt/minfo.d(356): Cyclic dependency between module ddmd.traits and ddmd.cond
ddmd.traits* ->
ddmd.attrib ->
ddmd.cond* ->
ddmd.expression ->

Pretty much all of LDC's D code is DDMD front-end code, master is at front-end version 2.071.2. I hope someone can try to build DMD 2.071.2 using 2.072.0 and see if a similar issue is found.

Reply via email to