On Tuesday, 13 February 2018 at 21:25:44 UTC, Jordi Sayol wrote:
El 13/02/18 a les 08:03, Martin Tschierschke via Digitalmars-d-learn ha escrit:
On Monday, 12 February 2018 at 21:18:01 UTC, Jordi Sayol wrote:
El 12/02/18 a les 21:56, Martin Tschierschke via Digitalmars-d-learn ha escrit:
I just started to play around with D again on my notebook at home and realized,
that I have a broken installation.
Even the minimal D "hello world" throws an error at execution. Speicherzugriffsfehler (Speicherabzug geschrieben) aka. core dump

Compiling with ldc2 still works.
Any hint?




d-apt <http://d-apt.sourceforge.net/>

After setting ulimit -c unlimited to get the core dumped, I took a look with gdb, to find a hint, now realizing, that it is probably the same problem as here: https://forum.dlang.org/thread/jjaynewwdsyntyehv...@forum.dlang.org?page=1


A fresh install from d-apt on Ubuntu 16.04 32-bit, and everything worked fine.


I tried a lot, there is special bug new on ubuntu 17.10 in
/etc/apt/sources.list.d/d-apt.list

!!! I had to change http://... to https://


Before that I imported the key with
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys EBCF975E5BA24D5E

I am not sure if this was necessary, probably not.

Than I was able to call

sudo apt-get update && sudo apt-get -y --allow-unauthenticated install --reinstall d-apt-keyring && sudo apt-get update

and install with

sudo apt-get install dmd-compiler dub

But unfortunately still the same core dump.

Is there anyone using Ubuntu 17.10 32 Bit?

I will downgrade to 16.04., the dist-upgrade to 17.10 was a mistake, resulting in problems with startx and newer kernels so I have to use 4.10.

Reply via email to