On Wednesday, 14 February 2018 at 11:23:48 UTC, Andrea Fontana wrote:
On Wednesday, 14 February 2018 at 11:16:25 UTC, Martin Tschierschke wrote:
Ok, good to know!
I started with 16.04 and made the initial mistake to take the 32 Bit version,
do you use 32 or 64 Bit?

64bit of course!

Andrea

After this info, I made the step to change to Ubuntu 17.10 64 Bit.
And - it works!

But the installation via apt-get is not working without the steps already mentioned in the post before! (s/http/https/ and manually import of the public key)

This (from https://dlang.org/download.html) is outdated for 17.10.

sudo wget http://master.dl.sourceforge.net/project/d-apt/files/d-apt.list -O /etc/apt/sources.list.d/d-apt.list sudo apt-get update && sudo apt-get -y --allow-unauthenticated install --reinstall d-apt-keyring
sudo apt-get update && sudo apt-get install dmd-compiler dub


Reply via email to