Am 2018-02-12 16:35, schrieb Irrwahn:
$ dpkg -l | fgrep libpolkit-backend
rc  libpolkit-backend-1-0:i386            0.105-9+devuan1
    i386         PolicyKit backend API
ii  libpolkit-backend-1-0-systemd:i386    0.105-18+devuan2.4
      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Now, there's your problem! :)

You should have one of:
        libpolkit-backend-1-0-elogind
or, probably more fittingly in your case:
        libpolkit-backend-1-0-consolekit
installed.

Cause is the recent polkit update:

Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  libpolkit-backend-1-0-systemd libpolkit-gobject-1-0-systemd
The following packages will be REMOVED:
  libpolkit-backend-1-0 libpolkit-gobject-1-0
The following NEW packages will be installed:
  libpolkit-backend-1-0-systemd libpolkit-gobject-1-0-systemd
The following packages will be upgraded:
  libpolkit-agent-1-0 policykit-1
2 upgraded, 2 newly installed, 2 to remove and 0 not upgraded.
Need to get 162 kB of archives.
After this operation, 147 kB disk space will be freed.
Get:1 http://pkgmaster.devuan.org/merged ascii/main amd64 policykit-1 amd64 0.105-18+devuan2.4 [59.8 kB] Get:2 http://pkgmaster.devuan.org/merged ascii/main amd64 libpolkit-agent-1-0 amd64 0.105-18+devuan2.4 [22.1 kB] Get:3 http://pkgmaster.devuan.org/merged ascii/main amd64 libpolkit-gobject-1-0-systemd amd64 0.105-18+devuan2.4 [38.5 kB] Get:4 http://pkgmaster.devuan.org/merged ascii/main amd64 libpolkit-backend-1-0-systemd amd64 0.105-18+devuan2.4 [41.4 kB]
apt-listchanges: Reading changelogs...
Fetched 162 kB in 0s (340 kB/s)
dpkg: libpolkit-backend-1-0:amd64: dependency problems, but removing anyway as you requested:
 policykit-1 depends on libpolkit-backend-1-0 (>= 0.99).

Removing libpolkit-backend-1-0:amd64 (0.105-9+devuan1) ...
Preparing to unpack .../policykit-1_0.105-18+devuan2.4_amd64.deb ...
Unpacking policykit-1 (0.105-18+devuan2.4) over (0.105-9+devuan1) ...
Preparing to unpack .../libpolkit-agent-1-0_0.105-18+devuan2.4_amd64.deb ... Unpacking libpolkit-agent-1-0:amd64 (0.105-18+devuan2.4) over (0.105-9+devuan1) ...

dpkg: libpolkit-gobject-1-0:amd64: dependency problems, but removing anyway as you requested:
 consolekit depends on libpolkit-gobject-1-0 (>= 0.94).
 policykit-1-gnome depends on libpolkit-gobject-1-0 (>= 0.99); however:
  Package libpolkit-gobject-1-0:amd64 is to be removed.
 colord depends on libpolkit-gobject-1-0 (>= 0.99).
 network-manager depends on libpolkit-gobject-1-0 (>= 0.104); however:
  Package libpolkit-gobject-1-0:amd64 is to be removed.
 upower depends on libpolkit-gobject-1-0 (>= 0.99).
 udisks2 depends on libpolkit-gobject-1-0 (>= 0.101); however:
  Package libpolkit-gobject-1-0:amd64 is to be removed.
policykit-1 depends on libpolkit-gobject-1-0 (= 0.105-18+devuan2.4); however:
  Package libpolkit-gobject-1-0:amd64 is to be removed.
libpolkit-agent-1-0:amd64 depends on libpolkit-gobject-1-0 (= 0.105-18+devuan2.4).

Removing libpolkit-gobject-1-0:amd64 (0.105-9+devuan1) ...
Selecting previously unselected package libpolkit-gobject-1-0-systemd:amd64. Preparing to unpack .../libpolkit-gobject-1-0-systemd_0.105-18+devuan2.4_amd64.deb ...
Unpacking libpolkit-gobject-1-0-systemd:amd64 (0.105-18+devuan2.4) ...
Selecting previously unselected package libpolkit-backend-1-0-systemd:amd64. Preparing to unpack .../libpolkit-backend-1-0-systemd_0.105-18+devuan2.4_amd64.deb ...
Unpacking libpolkit-backend-1-0-systemd:amd64 (0.105-18+devuan2.4) ...
Setting up libpolkit-gobject-1-0-systemd:amd64 (0.105-18+devuan2.4) ...
Setting up libpolkit-agent-1-0:amd64 (0.105-18+devuan2.4) ...
Setting up libpolkit-backend-1-0-systemd:amd64 (0.105-18+devuan2.4) ...
Processing triggers for libc-bin (2.24-11+deb9u1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for dbus (1.10.22-1+devuan1) ...
Setting up policykit-1 (0.105-18+devuan2.4) ...
Installing new version of config file /etc/pam.d/polkit-1 ...


_______________________________________________
Dng mailing list
Dng@lists.dyne.org
https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng

Reply via email to