On Friday, 31 December 2021 17:40:58 GMT Patrick Wigmore wrote:
> This looks like it should be a valid command, based on the
> configuration you listed and according to the amixer man page that's
> in the Debian bullseye alsa-utils package.

It was certainly valid when I originally wrote it about 5 years ago!  It has 
worked throughout until this upgrade.

> Are you saying that the "amixer: Invalid command!" error is produced
> when you run that amixer command directly?
> In other words, have you ruled out the possibility that the Python
> program has somehow begun to pass unexpected arguments to amixer?

Yes.  It fails from the shell and from the program.  In the Python program it 
is passed to the OS using:

subprocess.call(['amixer', '-c', '0', 'set', 'PCM', 'playback', tower_vol])

with tower_vol having been set previously.

As I say that line of code has worked for many years until now. 

(I dropped the 'playback in the command I gave in this thread because it was 
basically straight out of the man page.  It still fails if I add 'playback'.)


                Terry Coles

  Next meeting: Online, Jitsi, Tuesday, 2022-01-04 20:00
  Check to whom you are replying
  Meetings, mailing list, IRC, ...  http://dorset.lug.org.uk
  New thread, don't hijack:  mailto:dorset@mailman.lug.org.uk

Reply via email to