On 18/05/2022 09:48, Terry Coles wrote:
On Wednesday, 11 May 2022 09:35:11 BST Terry Coles wrote:
Does anyone else have this keyboard or can hazard a guess as to what has
gone wrong?  I appear to be able to map some at least of the media keys,
but then they aren't remembered after a reboot.
Not a lot of response to this ;-(

Since I posted the above, I'd also posted on Launchpad (the (K)Ubuntu bug/
queries tool).  There wasn't a huge response there either; mainly outlining
the use of xev in a console to check that the buttons were working; I'd
already tried this anyway and they were.   The other suggestion was using the
Desktop Settings to assign the keys.  I'd already done this also, with no

I then tried several things:

I spent a happy hour or so trying different live distros to see if the
behaviour changed and it certainly did! This problem is a bit like a
chameleon; it changes it's behaviour depending on what is happening. Here's a
summary of what I saw in Clementine and Rhythmbox in the various distros:

1. In Kubuntu 22.04, I got no Play/Pause button support at all, the Stop
button worked and the Next and Previous Track buttons worked OK  but only when
the player had focus.

2. In Ubuntu 22.04 (clean live installation) the Play/Pause button worked but
the Next and Previous Track buttons jumped several tracks at a time.

3. In Linux Mint 20.3 (clean live installation), the Play/Pause button worked
with Next and Previous Track buttons only working some of the time !!!!

At the time I thought that the problem was the lack of CyMotion Master Linux
keyboard driver support, eg the driver that I installed originally or the
kernel has had something dropped.

I then bought a nice shiny new Logitech G213 keyboard.and the symptoms changed
yet again:

I still couldn't get the Play/Pause button to work, but Stop, Next Track and
Previous Track all worked fine. The Volume Up, Volume Down and Volume Mute all
worked as advertised, so this was definitely a step forward (plus the keys
light up very prettily, which can't be bad with my ageing eyes). :-)  However,
the button that I use the most still didn't work; Play/Pause.

The following day, I booted up and the Play/Pause button worked !!!! I have no
explanation for this; there were no updates applied after the tests on the
previous afternoon and I did reboot after I plugged the new keyboard in.  I
was happy. :-)

However...  This morning when I booted up, the Play/Pause key was not working
again  ;-(

So what could be common to three distros (Kubuntu, Ubuntu and Mint) two
different keyboards, two different players (Clementine and RhythmBox) and also
be ephemeral in the way described above?

Any ideas anyone?

In terms of commonality, all the distros are Ubuntu-based, so might have the same issues for that reason. Linux Mint Cinnamon at least uses a service to watch and send the actions to the player (Firefox/VLC/etc).

Maybe try something Debian-based, like LMDE, or Fedora?

Other than that, no immediate ideas.


 Next meeting: Online, Jitsi, Tuesday, 2022-06-07 20:00
 Check to whom you are replying
 Meetings, mailing list, IRC, ...  http://dorset.lug.org.uk
 New thread, don't hijack:  mailto:dorset@mailman.lug.org.uk

Reply via email to