On Apr 17, 2009, at 3:12 PM, Stewart Smith wrote:
On Fri, Apr 17, 2009 at 10:33:25AM -0400, Jay Pipes wrote:
Baron Schwartz wrote:
On Mon, Apr 13, 2009 at 9:12 PM, Stewart Smith <[email protected]
> wrote:
But this is more performance schema than information schema.
Is it a good idea to follow MySQL's lead in separating those two?
Depends. If MySQL separated them b/c of the current I_S
implementation's
performance problems, then no. If for some other reason, perhaps...
There is a standard for I_S, so we should follow that where we can.
In my mind, the sep is I_S is standardised while a PERF_SCHEMA or
whatever is whatever we can grab from internals that may be useful to
people. i.e. not standard at all, not data dictionary based - but
rather
tied to internals.
Why not call it "mysql_schema" (or in the case of this discussion,
"drizzle_schema"), implement things how you want, and then plop i_s on
top (again, using PostgreSQL as an example here).
_______________________________________________
Mailing list: https://launchpad.net/~drizzle-discuss
Post to : [email protected]
Unsubscribe : https://launchpad.net/~drizzle-discuss
More help : https://help.launchpad.net/ListHelp