I will try to answer as best I could ya @Juanan,

Q: Is there any reason for creating a themes folder in /edx/app/edxapp?
A: The answer is no, i just follow the suggestion location privided in the 
documentation. Or if i think again, maybe it should be outside of 
edx-platform repo, to not interfere with the platform git repositories.

Q: After installing your starter-theme, there are some 404 errors in the 
log file
A: Did you follow the step i mention to update the assets using paver? i 
have been test it, and it works on eucalyptus instance fullstack. or maybe 
you use different stack?

Q: In your article you mention that the templates/ folder should exist at 
the same level that the static/ folder, but this templates/ folder is also 
missing in your repo.
A: Oh ya, maybe i must edit that 'should exist' word, that templates folder 
must exist if we want to overrides some default template OpenEdx or want to 
add new templates. So, in starter-theme repo, it doesn't matter because i 
did'nt create new templates or override something.

Q: Some Screenshot?
A: Here you go https://github.com/dehamzah/starter-theme-openedx 
i already push it to the repo readme.


On Saturday, September 17, 2016 at 8:28:20 PM UTC+7, Juanan Pereira wrote:
>
> Hi Abhilash, 
>
> On Sat, Sep 17, 2016 at 6:35 AM,  <abhi...@nextbig3d.com <javascript:>> 
> wrote: 
> > Since you are using the latest Eucalyptus.2 release, read the 
> instructions 
> > in the below blog (it describes to right way to do theming in eucalyptus 
> > release). Then proceed to implement the same using the github repo (2nd 
> > link). It worked for me and its up on production now. 
> > blog : https://dehamzah.com/openedx/comprehensive-theming-on-openedx/ 
> > github : https://github.com/dehamzah/starter-theme-openedx 
>
>
> Great explanation, thanks! Even though it is oriented to fullstack it 
> also helped me to start fiddling around with themes in devstack. 
>
> I have some related questions and suggestions. 
>
> * Is there any reason for creating a themes folder in /edx/app/edxapp 
> instead of using the already existing 
> /edx/app/edxapp/edx-platform/themes ? 
>
> * After installing your starter-theme, there are some 404 errors in 
> the log file: 
> [17/Sep/2016 08:46:04] "GET 
> /static/starter-theme/starter-theme/images/kids.jpeg HTTP/1.1" 404 
> 1844 
> [17/Sep/2016 08:46:04] "GET 
> /static/starter-theme/fonts/OpenSans/OpenSans-Regular-webfont.woff2 
> HTTP/1.1" 404 1889 
> [17/Sep/2016 08:46:04] "GET 
> /static/starter-theme/fonts/OpenSans/OpenSans-Semibold-webfont.woff2 
> HTTP/1.1" 404 1892 
> [17/Sep/2016 08:46:04] "GET 
> /static/starter-theme/fonts/OpenSans/OpenSans-Regular-webfont.woff 
> HTTP/1.1" 404 1886 
> [17/Sep/2016 08:46:04] "GET 
> /static/starter-theme/fonts/OpenSans/OpenSans-Semibold-webfont.woff 
> HTTP/1.1" 404 1889 
> [17/Sep/2016 08:46:05] "GET 
> /static/starter-theme/fonts/OpenSans/OpenSans-Semibold-webfont.ttf 
> HTTP/1.1" 404 1886 
> [17/Sep/2016 08:46:05] "GET 
> /static/starter-theme/fonts/OpenSans/OpenSans-Regular-webfont.ttf 
> HTTP/1.1" 404 1883 
>
> Basically, WebFonts and an image (kids.jpeg). The fonts are really 
> missing in your GitHub repo, but the jpeg image is there, so I suppose 
> that there is some linking or path issue here. 
>
> * In your article you mention that the templates/ folder should exist 
> at the same level that the static/ folder, but this templates/ folder 
> is also missing in your repo. It would be great if you could provide 
> it. 
>
> In order to double check that the configuration is working ok, could 
> it be possible to also add an screenshot of the final page with the 
> starter-theme template applied? 
>
> Thanks again. 
>
>
> -- 
> Greetings, 
>
> Juanan Pereira 
>

-- 
You received this message because you are subscribed to the Google Groups 
"General Open edX discussion" group.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/edx-code/a6c36def-3eca-4d1c-adb4-6824c13444c1%40googlegroups.com.

Reply via email to