I had the problem of power creep and the fix was just as described.
Adjusting the drive to the transmitter fixed it. 

-----Original Message-----
From: elecraft-boun...@mailman.qth.net <elecraft-boun...@mailman.qth.net> On
Behalf Of Kenneth Christiansen
Sent: Tuesday, March 13, 2018 4:57 PM
To: Jim N7US <j...@n7us.net>
Cc: Wes Stewart <wes_n...@triconet.org>; Elecraft Reflector
<Elecraft@mailman.qth.net>
Subject: Re: [Elecraft] K3S Power Creep (again)

Power Creep

I bet each one of you that has this problem has one defective output power
transistor. The remaining transistor can reach full power but it takes a
while. Talk to Elecraft service and ask them if they think that is your
problem and if it is then make arrangements to get it fixed.

Good luck and hope this can fix your problems.

73

Ken W0CZ


Sent from my iPad

> On Mar 13, 2018, at 4:19 PM, Jim N7US <j...@n7us.net> wrote:
> 

______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:Elecraft@mailman.qth.net

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html Message
delivered to marvwhee...@nwlink.com

______________________________________________________________
Elecraft mailing list
Home: http://mailman.qth.net/mailman/listinfo/elecraft
Help: http://mailman.qth.net/mmfaq.htm
Post: mailto:Elecraft@mailman.qth.net

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html
Message delivered to arch...@mail-archive.com

Reply via email to