On Fri, 1 Feb 2019, Gene Heskett wrote:

Date: Fri, 1 Feb 2019 06:37:25 -0500
From: Gene Heskett <ghesk...@shentel.net>
Reply-To: "Enhanced Machine Controller (EMC)"
    <emc-users@lists.sourceforge.net>
To: emc-users@lists.sourceforge.net
Subject: Re: [Emc-users] For PCW

On Wednesday 30 January 2019 17:18:09 Gene Heskett wrote:

On Wednesday 30 January 2019 15:58:30 Peter C. Wallace wrote:
Now I've got one for you Peter. I have written that file with the
extra pwmgen on pins 5-6 of p2, twice, and --verified it. But the
only place I can see that 2nd pwmgen is in a mesaflash --device
5i25 --readhmid output. It is NOT showing anyplace else.
?????????? Anyplace else, and P2 is all gpio. Jumper on 5i25 set
wrong? I gave it a good 30 seconds dead time before I hit the
power button to reboot, which should have been long enough to
reset it.  So whats next?

Thanks Peter

You probably have the PWMgen disabled in your hal file (in the hm2
driver load line)

Thanks, that was it.

Now, in setting it up in my .hal's, I can get pwmgen.1. out of p2 in
order to drive Jon's pwm-servoamp, and I have setup both pwmgens in
parallel, and I seem to be controlling spindir and spinena, but I am not
seeing the analog out on hm2_5i25.0.7i76.0.0.spinout. Do I need to apply
a ground on tb4-1, and some of the local 12volts to tb4-3 just to demo
that its working?  It makes sense but I'd druther be safe by asking.

Yes, the 7I76(D)s analog spindle control is an isolated potentiometer replacement device so needs an external 10 or 12V power source (15V ABS MAX)
normally this comes from a VFD

In addition to setting hm2_5i25.0.7i76.0.0.spinout (to some fraction of the current scale value) you need hm2_5i25.0.7i76.0.0.spinena set true to get analog out


I can see the other pwmgen.1 on its p2 pin, so routing that to the
pwm-servoamp in the G0704 will not be a problem. But the 6040 has a vfd
and will use the spinout 0-10 volt analogue signal.

What I'm trying to do is set this up so essentially the same bit of hal
stuff works for both machines and only the signal wiring in the control
box is different.

One potential problem might be needing a delay between the enables and
the boot module for the pwm-servo amp in case the opto's in the
isolation are slow, but thats a bridge I'll have to cross when I get to
it. I built the original boot module to bang it a bit harder, and 5
times in each direction, so its probably enough.

Thanks Peter.

Cheers, Gene Heskett
--
"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>



_______________________________________________
Emc-users mailing list
Emc-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/emc-users


Peter Wallace
Mesa Electronics

(\__/)
(='.'=) This is Bunny. Copy and paste bunny into your
(")_(") signature to help him gain world domination.



_______________________________________________
Emc-users mailing list
Emc-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/emc-users

Reply via email to