On Tue, 24 Jul 2007 20:08:29 +0200 Peter Wehrfritz <[EMAIL PROTECTED]> wrote:
> The current functions names of many Ecore_Data functions don't fit > into the common efl-naming schema. For example ecore_list_set_free_cb > should be ecore_list_free_cb_set. Hence I would propose to change the > API of those functions to follow the common-naming schema. Also I > like to rename ecore_list_nodes to ecore_list_count to be more > conform with other similar functions like ecore_hash_count. Since > only the function names will be changed, it can be easily done by a > script and wouldn't break any app in cvs. We could add aliases for > apps outside of the cvs tree, so they can move smoothly to the new > names. The only downside would be the massive commit mails :). I'm still feverish with this dreaded lurgy, but I like the idea in principle. It also pleases me that you covered my pet hate. B-) I say go for it, but I will review these comments when my brain works better.
signature.asc
Description: PGP signature
------------------------------------------------------------------------- This SF.net email is sponsored by: Splunk Inc. Still grepping through log files to find problems? Stop. Now Search log events and configuration files using AJAX and a browser. Download your FREE copy of Splunk now >> http://get.splunk.com/
_______________________________________________ enlightenment-devel mailing list [email protected] https://lists.sourceforge.net/lists/listinfo/enlightenment-devel
