On Tue, 24 Jul 2007 20:08:29 +0200 Peter Wehrfritz <[EMAIL PROTECTED]>
babbled:

ecore_file has a few bad crufty ones too.

> The current functions names of many Ecore_Data functions don't fit into 
> the common efl-naming schema. For example ecore_list_set_free_cb should 
> be ecore_list_free_cb_set. Hence I would propose to change the API of 
> those functions to follow the common-naming schema. Also I like to 
> rename ecore_list_nodes to ecore_list_count to be more conform with 
> other similar functions like ecore_hash_count. Since only the function 
> names will be changed, it can be easily done by a script and wouldn't 
> break any app in cvs. We could add aliases for apps outside of the cvs 
> tree, so they can move smoothly to the new names. The only downside 
> would be the massive commit mails :).
> 
> Here a list of the functions, which I would rename:
> 
> ecore_list_nodes        ecore_list_count
> ecore_list_is_empty        ecore_list_empty_is
> ecore_list_set_free_cb        ecore_list_free_cb_set
> ecore_dlist_nodes        ecore_dlist_count
> ecore_dlist_is_empty        ecore_dlist_empty_is
> ecore_dlist_set_free_cb        ecore_dlist_free_cb_set
> ecore_hash_set_free_key        ecore_hash_free_key_cb_set
> ecore_hash_set_free_value    ecore_hash_free_value_cb_set
> ecore_hash_set_hash        ecore_hash_hash_set
> ecore_plugin_get_available    ecore_plugin_available_get
> ecore_sheap_set_free_cb        ecore_sheap_free_cb_set
> ecore_sheap_set_compare        ecore_sheap_compare_set
> ecore_sheap_set_order        ecore_sheap_order_set
> ecore_tree_is_empty        ecore_tree_empty_is
> ecore_tree_get_closest_larger    ecore_tree_closest_larger_get
> ecore_tree_get_closest_smaller    ecore_tree_closest_smaller_get
> ecore_tree_add_node        ecore_tree_node_add
> ecore_tree_remove_node        ecore_tree_node_remove
> ecore_tree_set_free_value    ecore_tree_free_value_cb_set
> ecore_tree_set_free_key        ecore_tree_free_key_cb_set
> 
> and here a list of functions about I'm unsure if they should be renamed 
> or not:
> 
> ecore_list_append_list
> ecore_list_prepend_list
> ecore_list_remove_first
> ecore_list_remove_last
> ecore_list_goto_first
> ecore_list_goto_last
> ecore_list_goto_index
> ecore_dlist_prepend_list
> ecore_dlist_remove_first
> ecore_dlist_remove_last
> ecore_dlist_goto_first
> ecore_dlist_goto_last
> ecore_dlist_goto_index
> 
> I've you'll like the idea, I'll do the changes.
> 
> Peter
> 
> 
> -------------------------------------------------------------------------
> This SF.net email is sponsored by: Splunk Inc.
> Still grepping through log files to find problems?  Stop.
> Now Search log events and configuration files using AJAX and a browser.
> Download your FREE copy of Splunk now >>  http://get.splunk.com/
> _______________________________________________
> enlightenment-devel mailing list
> [email protected]
> https://lists.sourceforge.net/lists/listinfo/enlightenment-devel
> 


-- 
------------- Codito, ergo sum - "I code, therefore I am" --------------
The Rasterman (Carsten Haitzler)    [EMAIL PROTECTED]
裸好多
Tokyo, Japan (東京 日本)

-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>  http://get.splunk.com/
_______________________________________________
enlightenment-devel mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel

Reply via email to