So half way through typing that I edited out part of what I said, and may have 
not been clear after that.

When they do the lookup on the IP address, they are looking at the source of 
the connection.


From: listsad...@lists.myitforum.com [mailto:listsad...@lists.myitforum.com] On 
Behalf Of Kennedy, Jim
Sent: Thursday, February 8, 2018 9:53 AM
To: exchange@lists.myitforum.com
Subject: [Exchange] RE: Earthlink Contact?

They are looking for fully circular DNS and I am surprised you are not having 
trouble with other large ISP’s.

Circular DNS is defined as:
HELO Mailout.yourdomain.com from 192.168.10.1
A record for Mailout.yourdomain.com must be 192.168.10.1
192.168.10.1 must resolve to mailout.yourdomain.com

You are connecting from two different IP’s with two different connections, so 
you can’t meet the above. I don’t know how you do that. But the check I 
describe is widely in use. I don’t think it is an RFC but have never checked.


From: listsad...@lists.myitforum.com<mailto:listsad...@lists.myitforum.com> 
[mailto:listsad...@lists.myitforum.com] On Behalf Of Mayo, Bill
Sent: Wednesday, February 7, 2018 4:46 PM
To: exchange@lists.myitforum.com<mailto:exchange@lists.myitforum.com>
Subject: [Exchange] RE: Earthlink Contact?

My attempts at postmas...@earthlink.net<mailto:postmas...@earthlink.net> and 
trou...@earthlink.net<mailto:trou...@earthlink.net> did not work, so I tried 
the Twitter route. It took a while, but I did ultimately get a response today 
where they gave me a phone number to call. So, thanks to Michael and everyone 
else that responded. That said, based on the conversation that I had, I would 
appreciate a reality check.

We have 2 different ISPs and load balance outbound SMTP connections, as well as 
inbound DNS queries. So, we basically have 2 different IP’s that are used at 
the edge. We have an MX record that points to the domain name. DNS lookups to 
that domain name will return one of the 2 IP’s. Both of those IP’s will reverse 
lookup to the domain name. The HELO/EHLO greeting from the server gives the 
same domain name as the MX record. Additionally, we have an SPF record that 
indicates both of those IP’s.  What Earthlink seems to be initially suggesting 
is that they are doing an A record lookup of the domain name and comparing that 
to the connecting IP address (which seems contrary to the error message). In 
our setup, this will not always be a match. I can understand that they would do 
a reverse DNS on the IP to make sure it matches the HELO/EHLO greeting, and I 
can understand that they might also do an SPF and/or MX lookup to make sure 
that matches. I don’t understand doing a forward lookup and comparing that to 
the IP, since I don’t think that having multiple A records for a given domain 
name is particularly uncommon. Is what they are suggesting a legitimate issue?

Bill Mayo

From: listsad...@lists.myitforum.com<mailto:listsad...@lists.myitforum.com> 
[mailto:listsad...@lists.myitforum.com] On Behalf Of Michael B. Smith
Sent: Friday, February 02, 2018 10:49 AM
To: exchange@lists.myitforum.com<mailto:exchange@lists.myitforum.com>
Subject: [Exchange] RE: Earthlink Contact?

Twitter shame them. @Earthlink and @weCareEarthlink

And yes, I’m completely serious.

From: listsad...@lists.myitforum.com<mailto:listsad...@lists.myitforum.com> 
[mailto:listsad...@lists.myitforum.com] On Behalf Of Mayo, Bill
Sent: Friday, February 2, 2018 10:16 AM
To: exchange@lists.myitforum.com<mailto:exchange@lists.myitforum.com>
Subject: [Exchange] Earthlink Contact?


We are having emails sent to Earthlink being intermittently rejected with the 
reason “550 ERROR: No or mismatched reverse DNS (PTR) entries”. We have done 
quite a bit of troubleshooting on this, and the problem does not appear to be 
on our end. I actually have logs that show 2 consecutive messages where the 
first one is accepted and the second one rejected. I also see “421 Load too 
high” messages in the log from Earthlink when these happen.

I am trying to figure out how to contact Earthlink to get some assistance, but 
am striking out with how to contact them. The have a special page if you are 
getting a “blocked by EarthLink” response, but that doesn’t apply here. There 
contact page has chat support that requires you to provide an Earthlink 
account. Does anybody know how to get in touch with someone at Earthlink that 
could actually help with this problem?



Bill Mayo

Reply via email to