Andy Ross

> > No - nothing else has been modified. I've gone back to the cvs-head
> version
> > of source and data. This is the _only_ change in the code anywhere:
> >
> > <!--<control-input axis="/controls/engines/engine[0]/throttle"
> >                    control="THROTTLE"/>-->
> >     <control-input axis="/controls/engines/engine[0]/boost-control"
> >                    control="THROTTLE"/>
> Bingo.

Not. At least, only in the sense of RTB. This is where we came in. It might
not produce any thrust, but it should solve shouldn't it?

> That's the bug.  You commented out the throttle!  
> How is the
> engine supposed to produce thrust when the throttle input is zero? :)
> You need *both* the inputs for them to be added together.

Yes. I wish!

Next trial:

Config file:

<control-input axis="/controls/engines/engine[0]/throttle"
axis="/controls/engines/engine[0]/boost-control" control="THROTTLE"/>


YASim solution results:
       Iterations: 1
 Drag Coefficient: 1000
       Lift Ratio: 1
       Cruise AoA: 0
   Tail Incidence: -0
Approach Elevator: 0
            CG: -3.412, 0.000, -0.201

Do you suppose that whatever is or isn't in
Is breaking YASim?

And I've tried initializing "/controls/engines/engine[0]/boost-control" in
hardcode, and in Nasal, and in .XML - no difference. I can only think that
initialization creates the property with a null value, and then only gives
it the correct value after YASim has tried to use it and failed. I can show
that this is the case with NASAL, otherwise I wouldn't need this: 

if (mp == nil){mp = 0};

Any better theory? 


Flightgear-devel mailing list

Reply via email to