At 09:15 AM 11/20/02, you wrote:
Please
review, change and comment.

re TBD section

1. strongy encourage m_ for instance variables, if only to eliminate
having to qualify similarly named assignments like
this.variable = variable

2. suggest s_ for statics and allow ALL_CAPS (underscores tolerated for this usage only)
for static final (ie literals)

3. Sadly I ~don't~ like the Sun style for brace placement, but I guess I learned in the
Fortran and PL/1 era. Guess I'm in the minority on that point ;-)

if (blahBlah){
line ;
line
} else {
line ;
line ;
}
vs
if (blahBlah)
{
line ;
line ;
}
else
{
line ;
line ;
}

4. I prefer Petzold's convention of placing a space before the terminating
semicolon (or even colon) which I believe he did for readability in books,
and which I do for readability by my senior, crt-weary, eyes.


' Best,
-Ralph

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]



Reply via email to