J.Pietschmann wrote:
Victor Mote wrote:

"checkstyle.pattern.publicmember" = "^f[A-Z][a-zA-Z0-9]*$", which is the


1. was this really our intent?

I'm not sure. Nevertheless, it was apparently made by well meaning
people who thought detailed naming conventions would help to spot
scope/type/semantic of an identifier easier. I've found again and
again that this sucks for a variety of reasons. Let's change it to


I don't think this was ever our intent. It was, I think, an issue whiich was discussed on the Wiki in relation to prefixes like "m_". It was rejected there, and because it was not proceded with, it has disappeared from both the wiki and the web page.

2. does anyone know what the "f" stand for?

"Field", I guess.

3. checkstyle actually suggests that "Variable 'ipd' must be private and
have accessor methods." Perhaps this is our preferred solution?

This is usually a good idea but may cause quite a bit of work.

Peter -- Peter B. West http://www.powerup.com.au/~pbwest/resume.html

--------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, email: [EMAIL PROTECTED]

Reply via email to