--- Finn Bock <[EMAIL PROTECTED]> wrote:
> > however, is probably preferable--the word
> "Property" 
> > figures quite highly in the spec!  Do you have a
> > problem remaining with it?
> Not at all, it is just that I though it would be

Good--we can stick with "Property" then.

> Indeed. Which package should the resulting rolled
> datatype/property be 
> placed in? My feeling says fop.datatypes (and the
> nested makers should 
> be unnested and placed in fop.fo.properties). But
> that is a separate 
> suggestion which does not have to be dealt with
> initially.

Yes, it doesn't matter right now--do what you think is
best, we can rearrange them later if needed. 
Unnesting is fine--I particularly liked the new
"PropertyMaker" class.

One issue--before I forget--in the FOPropertyMapping,
for the colors, we have a huge set of 

genericColor.addKeyword("blue", "#....");
genericColor.addKeyword("red", "#....");
etc... etc...

I just noticed, however, that the datatypes.ColorType
class already has color types predefined within it. 
Do we really need to have both?  I think we can get
rid of one or the other, correct?

> I still like 
> the null return and null test better than the
> alternatives tho.

OK.  Sounds good.  The patch looks fine to me.


Do you Yahoo!?
Yahoo! SiteBuilder - Free web site building tool. Try it!

Reply via email to