Hi Vincent,

I spent a couple of hours yesterday trying to get it working on my system (Feisty Ubuntu and using Sun Java 1.3.1_20-b03). Initially I had a little bit of tweaking to do as ant seems to want to use org.apache.xml.serializer.SerializerTrace which isn't bundled with the
default ant installation so I had to copy serializer.jar to the ant lib
folder.

Having got this working I experienced the same NoSuchMethodErrors that you did when I run the ant junit target. There seems to be no obvious reason for these errors. After this I tried to get this working I tried my old Windows setup (which used to build nicely with 1.3). It exhibited the same problem too. Very strange... if anyone else tries to build this I'd be interested to hear of about their experiences - and share the pain, so to speak ;-).

Adrian.

Vincent Hennebert wrote:
Ok, I’ve had enough. I’ve spent almost the whole day trying to build
a FOP distribution with Java 1.3. First trying to solve that problem of
Xalan not found. Then fighting to get JCE working, to finally still have
the corresponding testcase fail [1]. Then having cryptic
NoSuchMethodErrors here and there [2].

Creating an Eclipse project and setting up a 1.3 jdk allowed me to
compile and run the files from [2] with no problem. Compiling from the
commandline failed. Running build.xml from the Eclipse project failed
(same error as [2]). Setting the javac.source and javac.target to 1.3 in
build.properties doesn’t change anything.


I’m not gonna spend my week-end on figuring out how to get a 1.3 build.
That’s no fun and I have plenty of other more worthy things to do on
FOP. I don’t need 1.3 compatibility, I’ve not even used Java 1.3 ever in
my life, so I really don’t care about it.

If someone else wants to take care of the 1.3 build, I’m happy to leave
him holding the baby, the branch is ready to be tagged. Otherwise users
who need it will have to build FOP themselves from the source.

Vincent


[1]
junit-basic:
     [echo] Running basic functionality tests for fop.jar
    [junit] Testsuite: org.apache.fop.StandardTestSuite
    [junit] Tests run: 29, Failures: 1, Errors: 0, Time elapsed: 2,163 sec
    [junit]
    [junit] Testcase:
testPDFEncodingWithStandardFont(org.apache.fop.render.pdf.PDFEncodingTestCase):
      FAILED
    [junit] 3 PDFE_TEST_MARK_ markers must be found expected:<3> but was:<0>
    [junit] junit.framework.AssertionFailedError: 3 PDFE_TEST_MARK_
markers must be found expected:<3> but was:<0>
    [junit]     at
org.apache.fop.render.pdf.PDFEncodingTestCase.checkEncoding(PDFEncodingTestCase.java:140)
    [junit]     at
org.apache.fop.render.pdf.PDFEncodingTestCase.runTest(PDFEncodingTestCase.java:104)
    [junit]     at
org.apache.fop.render.pdf.PDFEncodingTestCase.testPDFEncodingWithStandardFont(PDFEncodingTestCase.java:73)
    [junit]
    [junit]
    [junit] Test org.apache.fop.StandardTestSuite FAILED

[2] Run ant junit-layout-standard
Or try the column-number_non-integer.fo file in test/fotree/testcases




Reply via email to