I'm using Cocoon 2.0.1. 

here's what I put inside my userconfig.xml

 <font metrics-file="c:\fop-0.20.3\msminch.xml">
  <font-triplet name="Arial" style="normal" weight="normal" /> 
  <font-triplet name="Arial" style="normal" weight="bold" /> 
  <font-triplet name="Arial" style="italic" weight="normal" /> 
  <font-triplet name="Arial" style="italic" weight="bold" /> 
  <font-triplet name="Arial" style="italic" weight="bold" family="serif" /> 
 </font>

I generated msminch.xml file with TTFReader utility from msmincho.ttc file.
I tried an option with file-embed too.

My PDF file doesn't show me chinese letters, it puts "#" instead.

I know that my XML-FO file is Ok. All fonts are on my PC, so I can see
Chinese in Internet Explorer.

What shall I look into to find my problem?

Argyn



> -----Original Message-----
> From: Argyn Kuketayev [mailto:[EMAIL PROTECTED]
> Sent: Friday, May 10, 2002 5:37 PM
> To: '[EMAIL PROTECTED]'
> Subject: RE: step-by-step instructions how to print Chinese in PDF?
> 
> 
> > After you've located a font, check with the font directory to get
> > the windows file name. It should be a TrueType font file ending
> > in .ttf.
> 
> 
> it's msmincho.ttc. I ran ttfreader, it generated me the HUGE 
> xml file ~400k.
> 
> How should I extract the only required fonts? I don't specify 
> any fonts
> explicitely inside my FO file, only font family serif or sans-serif.
> 
> Argyn
> 

Reply via email to