On 9/22/2016 5:15 AM, Warren Young wrote:
On Sep 21, 2016, at 2:06 PM, jungle Boogie <jungleboog...@gmail.com>
wrote:


I have installed mingw32-base and the installed version is
2013072200 and also mingw32-gcc-g++ with a version of 5.3.0-2

I don’t follow MinGW closely, but as I understand it, the mingw.org
project is moribund.  The 2013 release date suggests you’re using
mingw.org, but the GCC 5.3.0 spec suggests MinGW-W64, a fork of MinGW
that is actively maintained.

The MinGW mailing list would disagree that it is dead, but it has been a
long time since an update. Fortunately, fossil does not require bleeding
edges of anything in either build tools or library support.

If you do need a bleeding edge GCC on Windows, then the MinGW-W64 people can provide it. But be aware that there is a loud and large rift between the two projects, over a difference of interpretation of the license terms on MS API documentation. MinGW are very conservative, and refuse to include or support anything that can't be discovered from just the MSDN published reference manuals. The MinGW64 project is willing to consider the published Windows.h and related files to also be public API documentation despite the very threatening tone of the copyright notices in the files themselves.

That difference leads to differing levels of support for new and interesting features of Windows.


I installed MinGW and MSYS following the standard instructions a long time ago. I build (and test) fossil under MSYS's build of bash, and use it with no complaints on stock Windows ranging from XP to Win10 Pro across my organization's mixed bag of machines. Recently I started include OpenSSL support in my builds, and that came together with only a little hair-pulling and confusion.

Building under MSYS bash allows ./configure to just work. I long ago copied mingw32-make.exe to make.exe on my path and all is just ducky.

The test suites run just fine with a recent build of ActiveTcl also installed. I did have to use its package manager to add a JSON library (and I think one other, sha1 possibly?) to get all tests to run.

I also occasionally have built from the Windows CMD prompt, using the command make -f win/Makefile.mingw which generally also works for me, except that the resulting fossil.exe does not include OpenSSL. I suspect it is possible to make it do so, but I have not worked out the right additional configuration to make it happen.

The big advantage of a MingW32 build is that the result is a 32-bit binary that is linked against the same C runtime library DLL that ships natively in all versions of windows (at least since XP). Yes, that is officially not the recommended approach. But it is also the approach that until very recently MS themselves used for almost all bundled tools and utilities.

While I run a 64-bit Windows on my desk, I have yet to be convinced that there is a need for fossil.exe to be a 64 bit build and have not even attempted to do that as an experiment.


--
Ross Berteig                               r...@cheshireeng.com
Cheshire Engineering Corp.           http://www.CheshireEng.com/
+1 626 303 1602
_______________________________________________
fossil-users mailing list
fossil-users@lists.fossil-scm.org
http://lists.fossil-scm.org:8080/cgi-bin/mailman/listinfo/fossil-users

Reply via email to