On 28 Feb, Dimitry Andric wrote:
> On 27 Feb 2014, at 01:57, Don Lewis <truck...@freebsd.org> wrote:
>> On 26 Feb, Michael Butler wrote:
>>> On 02/18/14 12:10, Michael Butler wrote:
>>>> Is anyone else seeing firefox failing to install after the clang-3.4
>>>> merge? As in xpcshell dumping core ..
>>> An update ..
>>> Recompiling with GCC48 on -current yields the same result. Seems to run
>>> correctly when invoked from the command-line but seg-faults with "errno
>>> = 4" (invalid instruction) from the build
>>> Giving up and using the Linux port .. :-(
>> I've also seen this problem with clang-3.4 on i386.  It looks like a
>> clang bug to me.  Clang is putting ud2 instructions in its output which
>> are guaranteed to fault when it compiles nsAppRunner.cpp.  See
>> <http://www.freebsd.org/cgi/query-pr.cgi?pr=187103>.
>> I tried compiling the offending file with gcc46 and didn't see the
>> problem in the assembly output.
> Indeed, this is clang bug with stdcall calling conventions.  See the
> upstream bug http://llvm.org/PR19007 (thanks to Benjamin Kramer for
> reducing this).
> I have followed up on the bug with a workaround, which can be used until
> this bug is fixed upstream, and I can import the fix.

Thanks for the fast work!  The patched solve the problem for me and I
was able to install and run firefox on 11.0-CURRENT i386.

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to