Warner Losh wrote:
> In message <[EMAIL PROTECTED]> Mark Murray writes:
> : > In message <[EMAIL PROTECTED]> Warner Losh wri
> : tes:
> : > :         2) APM is now broken.  It worked after the ACPI integration,
> : > :            but after the SMPNG stuff neither apm -z nor the BIOS keys
> : > :            seems to suspend.
> : > 
> : > Turns out this isn't the case.
> : 
> : shutdown -p does not turn off the machine for me (Libretto 110ct).
> : 
> : zzz/apm -z gives me "apm: ioctl(APMIO_SUSPEND): Invalid argument"
> I noticed this with the first SMPNG kernel I tried.  The newer one
> this problem disappeared.  Don't know why it would matter, but I may
> have missed a commit while in new mexico.

It may be a kernel/world sync problem.  Although I don't know why the ioctl
argument would suddenly become invalid.  Maybe it passes in a struct ucred,
which changed in size just before the SMPng commit?

> Warner


John Baldwin <[EMAIL PROTECTED]> -- http://www.FreeBSD.org/~jhb/
"Power Users Use the Power to Serve!"  -  http://www.FreeBSD.org/

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to