I'm having panic with recent pccard/pcic changes on system boot.
The system is Sony VAIO PCG-Z505V/BP.

Here's the panic message:

kernel trap 12 with interrupts disabled

Fatal trap 12: page fault while in kernel mode
fault virtual address   = 0xc42ef780
fault code              = supervisor read, page not present
instruction pointer     = 0x8:0xc03b6b48
stack pointer           = 0x10:0xc8a7fb28
frame pointer           = 0x10:0xc8a7fb34
code segment            = base 0x0, limit 0xfffff, type 0x1b
                        = DPL 0, pres 1, def32 1, gran 1
processor eflags        = resume, IOPL = 0
current process         = 179 (pccardd)
kernel: type 12 trap, code = 0
Stopped at      sched_ithd+0x10:    movl  iths(%esi),%ecx

I've written down the trace output, but the first few lines scrolled
off the screen, so not included here. sorry :-(

bus_generic_setup_intr(c0e3f900,c0fd5a00,c0ff2780,81,c03c2708) at 
bus_generic_setup_intr(c0e3f500,c0fd5a00,c0ff2780,81,c03c2708) at 
bus_generic_setup_intr(c0e3f480,c0fd5a00,c0ff2780,81,c03c2708) at 
bus_generic_setup_intr(c0efa980,c0fd5a00,c0ff2780,81,c03c2708) at 
pcic_setup_intr(c0efa980,c0fd5a00,c0ff2780,81,c03c2708) at pcic_setup_intr+0x54
bus_generic_setup_intr(c0f04000,c0fd5a00,c0ff2780,81,c03c2708,c0f89c00,c0f89de0) at 
sioattach(c0fd5a00,0,c8a82d84,c023cb92,c0fd5a00) at sioattach+0x700
sio_pccard_attach(c0fd5a00,0,c0fd5a00,c0ff3700,1) at sio_pccard_attach+0xd
device_probe_and_attach(c0fd5a00,c0f06400,c0ff3700,c0485020,a) at 
allocate_driver(c0f06400,c0ff3700,c8a82e0c,c0485020,c7b13320) at allocate_driver+0xf4
crdioctl(c0485020,c0ac5006,c0ff3700,3,c7b13320,) at crdioctl+0x34b
spec_ioctl(c8a82e0c,c8a82e9c,c0280ab9,c8a82e0c,c0ff2f80) at spec_ioctl+0x26
spec_vnoperate(c8a82ec0,c0ff2f80,0,ac,c042f700) at spec_vnoperate+0x15
vn_ioctl(c0ff2f80,c0ac5006,c0ff3700,c7b13320,c7b1343c) at vn_ioctl+0x10d
ioctl(c7b13320,c8a82f80,8073140,8073100,0) at ioctl+0x20a
syscall(2f,2f,2f,0,80731000) at syscall+0x689
syscall_with_err_pushed() at syscall_with_err_pushed+0x1b

Here's the dmesg when it panics. Note that "pccard: card inserted, slot 0"
appears twice.

ACPI debug layer 0x0  debug level 0x0
Copyright (c) 1992-2001 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.0-CURRENT #0: Mon Jun 18 00:54:36 JST 2001
    [EMAIL PROTECTED]:/usr/src/sys/compile/JKPC11
Timecounter "i8254"  frequency 1193182 Hz
Timecounter "TSC"  frequency 595573410 Hz
CPU: Pentium III/Pentium III Xeon/Celeron (595.57-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x686  Stepping = 6
real memory  = 134152192 (131008K bytes)
avail memory = 125108224 (122176K bytes)
Preloaded elf kernel "kernel" at 0xc0554000.
Pentium Pro MTRR support enabled
Using $PIR table, 7 entries at 0xc00fdf50
acpi0: <SONY   Z3      > on motherboard
acpi_tz0: <thermal zone> on acpi0
acpi_button0: <Control Method Power Button Device> on acpi0
acpi_pcib0: <Host-PCI bridge> on acpi0
pci0: <PCI bus> on acpi_pcib0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <display, VGA> at 0.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX4 ATA33 controller> port 0xfcb0-0xfcbf at device 7.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
uhci0: <Intel 82371AB/EB (PIIX4) USB controller> port 0xfc60-0xfc7f at device 7.2 on 
pci_cfgintr_unique: hard-routed to irq 9
pci_cfgintr: 0:7 INTD routed to irq 9
usb0: <Intel 82371AB/EB (PIIX4) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhub1: Philips Semiconductors hub, class 9/0, rev 1.10/1.10, addr 2
uhub1: 3 ports with 3 removable, self powered
umass0: Sony USB Memory Stick Slot, rev 1.10/1.31, addr 3
pci0: <bridge, PCI-unknown> at 7.3 (no driver attached)
pci0: <serial bus, FireWire> at 8.0 (no driver attached)
pcm0: <Yamaha DS-1E (YMF744)> mem 0xfecf0000-0xfecf7fff irq 9 at device 9.0 on pci0
pci0: <simple comms> at 10.0 (no driver attached)
fxp0: <Intel Pro 10/100B/100+ Ethernet> port 0xfcc0-0xfcff mem 
0xfed00000-0xfedfffff,0xfecff000-0xfecfffff irq 9 at device 11.0 on pci0
fxp0: Ethernet address 08:00:46:0e:5a:c4
inphy0: <i82555 10/100 media interface> on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
pci_cfgintr_unique: hard-routed to irq 9
pci_cfgintr: 0:12 INTA routed to irq 9
pcic0: <Ricoh RL5C475 PCI-CardBus Bridge> irq 9 at device 12.0 on pci0
pcic0: Memory mapped device, will work.
pcic0: PCI Memory allocated: 0x44000000
pccard0: <PC Card bus (classic)> on pcic0
acpi_ec0: <embedded controller> on acpi0
acpi_cmbat0: <Control method Battery> on acpi0
acpi_acad0: <AC adapter> on acpi0
acpi_acad0: Off Line
acpi_timer0: <24-bit timer at 3.579545MHz> on acpi0
npx0: <math processor> on motherboard
npx0: INT 16 interface
orm0: <Option ROMs> at iomem 0xc0000-0xcffff,0xdc000-0xdffff on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model GlidePoint, device ID 0
fdc0: direction bit not set
fdc0: cmd 3 failed at out byte 1 of 3
pmtimer0 on isa0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: Generic chipset (ECP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
ppi0: <Parallel I/O> on ppbus0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1: configured irq 3 not in bitmap of probed irqs 0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
unknown: <PNP0303> can't assign resources
unknown: <PNP0F13> can't assign resources
pcic0: Event mask 0xf
ad0: 14403MB <HITACHI_DK23BA-15> [29264/16/63] at ata0-master UDMA33
pccard: card inserted, slot 0
pcic0: debounced state is 0x30000419
pccard: card inserted, slot 0
pcic0: Event mask 0x9
Mounting root from ufs:/dev/ad0s2a
sio2 at port 0x2f8-0x2ff irq 9 slot 0 on pccard0
sio2: type 16550A

Here's what I have in rc.conf for pccard.

pccard_ifconfig="inet  netmask"
#pccardd_flags="-i 10 -i 11"

Hers's what I have in pccard.conf

irq     9 10 11

# Megahertz XJ/CC5560
card "U.S. Robotics" "XJ/CC5560"
        config  auto "sio" ?

Here's what I have in device.hints

hint.pcic.0.irq="10"    # Default to polling

Hope this helps,
           _ _    Munehiro (haro) Matsuda
 -|- /_\  |_|_|   Business Incubation Dept., Kubota Corp.
 /|\ |_|  |_|_|   1-3 Nihonbashi-Muromachi 3-Chome
                  Chuo-ku Tokyo 103-8310, Japan
                  Tel: +81-3-3245-3318  Fax: +81-3-3245-3315
                  Email: [EMAIL PROTECTED]

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to