Marcel Moolenaar wrote:
> On Wed, Sep 12, 2001 at 04:59:16PM -0700, Doug Ambrisko wrote:
> > I just tried using tap in current.  In both cases I don't see the
> > /dev/tapX devices with devfs and accessing it without devfs doesn't
> > work reporting "Device not configured".  I tried it as a module and
> > built into the kernel.  Does anyone have this working?
> My guess is that the breakage is related to the recent commits
> that were made to if_tap. VMWare doesn't work anymore on -current
> because the NG modules aren't loaded. These, AFAICT, depend on
> the device.
> So, at this time I can only acknowledge the breakage. I probably
> won't have the time to suggest or implement fixes.

the recent if_tap patch implements device cloning (a-la tun(4)).
unfortunately i had to change vmnet device mask and that affects
VMWare port because minor numbers for vmnet devices has changed.

bottom line: in order to make vmnet working you need to change
minor numbers for vmnet device nodes. another solution would
be to link /dev/vmnet? to /compat/linux/dev/vmnet? 

port maintainer has been notified. i'm sorry for the trouble.


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to