Gvim will link against nonexistent libraries, some of them seem to
be derived from libXThrStub library name and some Xlib function
names, very weird. I'm unable to build working gvim either from
ports or by hand, also doesn't matter is it newest version or older
6.0 release. First thought something is wrong with my hand-compiled
XFree 4.2.0, but it isn't, XFree-4 port gave same results. I've
-current as of yesterday, certainly past of the latest md5-crypt.c
In the light of past events it seems to be something with linker or
perhaps binutils. Non-X vim will work fine.

myhakas:root# pwd
myhakas:root# ls -la vim
-rwxr-xr-x  1 root  wheel  1202570 Mar  9 15:01 vim
myhakas:root# ldd vim
        libXaw.so.7 => /usr/X11R6/lib/libXaw.so.7 (0x28158000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x281ab000)
        libncurses.so.5 => /usr/lib/libncurses.so.5 (0x281b8000)
        libc.so.5 => /usr/lib/libc.so.5 (0x281fa000)
        libXThrStub.XDeleteProperty => not found (0x0)
        libXThrStubXtVaGetValues => not found (0x0)
        libXThrStub.XDefaultScreen => not found (0x0)
        libXThrStub.XpmFreeAttributes => not found (0x0)
        libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x282b0000)
        libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x282c5000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x2830e000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x28317000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x2832d000)
        libXpm.so.4 => /usr/X11R6/lib/libXpm.so.4 (0x283e5000)
        libXThrStub.so.6 => /usr/X11R6/lib/libXThrStub.so.6 (0x283f3000)
myhakas:root# exit

Vallo Kallaste

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to